debian 的源文件可以用这个在线生成

在执行 apt-get update 的时候,可能会出现这种错误

E: GPG 错误:http://volatile.debian.org lenny/volatile InRelease: 明文签署文件不可用,结果为‘NODATA’(您的网络需要认证吗?)

这种错误可能是所选用的源与当前版本的不符,比如当前版本是 jessie ,而所用的源却是 lenny 的,

此外就是源的 GPG 密钥对没有安装

 

有一个在线生成 debian 的源文件的网站  https://debgen.xyz/

务必选对 debian 当前的版本,否则可能会提示PGP密钥认证问题

 

vim /etc/apt/sources.list

deb [arch=i386] http://ftp.cn.debian.org/debian/ jessie main contrib non-free
deb-src [arch=i386] http://ftp.cn.debian.org/debian/ jessie main contrib non-free

deb [arch=i386] http://ftp.cn.debian.org/debian/ jessie-updates main contrib non-free
deb-src [arch=i386] http://ftp.cn.debian.org/debian/ jessie-updates main contrib non-free

deb [arch=i386] http://security.debian.org/ jessie/updates main contrib non-free
deb-src [arch=i386] http://security.debian.org/ jessie/updates main contrib non-free

 

第二个问题,在执行 apt-get update 的时候,出现HTTPS错误

 

未发现软件包 apt-transport-https

# wget http://ftp.us.debian.org/debian/pool/main/a/apt/apt-transport-https_1.0.9.8.4_i386.deb
dpkg -i apt-transport-https_1.0.9.8.4_i386.deb”

这个软件的版本不宜最新的,因为它的依赖软件也会要求比系统当前较新的版本

原文链接:,转发请注明来源!

发表评论